Go back to home



We have detected that you are using ad blocking software.
The MR2 Australia forum is made possible by ad revenue.
Please disable your ad blocker to ensure that this site lives on.

Hot!3sgte Gen3 electric problem

Author
onesomelowkite
MR2 Aficionado
  • Total Posts : 46
  • Scores: 12
  • Reward points: 3651
  • Joined: 2014/04/03 15:51:56
  • Location: Melbourne
  • Status: offline
2024/03/05 02:11:43 (permalink)
0

3sgte Gen3 electric problem

Really need some help with my MkII.

After 10 years owning my gen3. Recently had encounter some electronic problems.

Car not always starts. The battery is 2 months old only. I just had my alternator and ignition distributor repaired. Spark plug replaced. But the issues is getting worse.

Started the car on Sunday morning then drove for few meters then it just die on my driveway.

Jump started then drove for few mins. I can feel the engine shaking badly then here was something had never happened before.
I could see the engine and battery lights occasionally flickering at bottom left.

It was scary then I went home recharged the battery from my garage. Next day Checked from the alternator, reading was 14.5. Battery reading was 13.4 when the engine was running. I understand 13.4 was not ideal, but full electronic wiring diagnosis is my last option as I don't know how to do it myself.

I then installed an extra 4ga cable with 120a fuses directly from the alternator to the car battery at the front.
Also add an extra ground cable from the battery. Hopefully this backup cables would make the car more stable.

I also installed a voltage monitor connected directly from the battery.

From the monitor The reading was drop from 13.4 to 11.8 after 5 mins of driving , the engine did not shake this time but the engine and battery light was started flickering again from the point where the reading was below 12v. I drove back home, parked the car then the reading was gone back up to 12.5 after the engine was off.

My mechanic told me my motor starter is not perfect. But Voltage drop during car drive can't cause by the starter right?
What cause the issue? I think the car need further diagnosis.
Alternator refused to charge after the engine was running hot? I cannot get the reading from the alternator while I was driving.
But the battery light flickering was something new. That indicated the problem from the alternator or from the battery? Battery is new, Alternator was just repaired.

Thanks in advance.
#1


0 Replies Related Threads

    Jump to:

    © 2024 APG vNext Trial Version 5.5