Go back to home



We have detected that you are using ad blocking software.
The MR2 Australia forum is made possible by ad revenue.
Please disable your ad blocker to ensure that this site lives on.

Hot!Misfire/ hesitation at low rpms

Author
BishoyIbrahim
MR2 Enthusiast
  • Total Posts : 7
  • Scores: 0
  • Reward points: 44
  • Joined: 2020/05/02 18:11:33
  • Status: offline
2020/07/27 19:31:52 (permalink)
0

Misfire/ hesitation at low rpms

Hey guys,
My 1990 NA SW20 has recently been having a problem where when I go to accelerate it will misfire and have very little torque till about 2000-3000 rpms (not exactly the same RPMS every time) where suddenly torque will go back to normal (it happens instantly and feels like a shove) and it will pull nicely without any misfires all the way to redline. This problem also seems to only happen after the car has warmed up as it will initially run normally after the first 3 or so minutes after a cold start. I noticed this problem after I cleaned my throttle body but I'm not sure if the problem is related to that since I have done it before and all was fine. I'm really not sure where to start but I think the problem might have something to do with the intake since if it was spark or fuel I would think the problem would get worse at higher RPMs but I'm still unsure.
 
Also, the car idles at a very good level but the engine has a slight misfire while idling and you can feel it vibrate excessively and randomly.
 
Otherwise it doesn't seem to be a major problem and nothing else seems to be effected but it makes driving the car very annoying. 
 
If anyone has encountered this problem or any have idea what might be wrong any advice is greatly appreciated. 
 
Cheers :)
#1


2 Replies Related Threads

    Rando
    MR2 Enthusiast
    • Total Posts : 10
    • Scores: 3
    • Reward points: 868
    • Joined: 2018/04/08 22:40:35
    • Status: offline
    Re: Misfire/ hesitation at low rpms 2020/07/28 08:37:37 (permalink)
    +1 (1)
    Did you reset the ECU after the TB service?
    #2
    BishoyIbrahim
    MR2 Enthusiast
    • Total Posts : 7
    • Scores: 0
    • Reward points: 44
    • Joined: 2020/05/02 18:11:33
    • Status: offline
    Re: Misfire/ hesitation at low rpms 2020/07/28 10:03:29 (permalink)
    0
    Rando
    Did you reset the ECU after the TB service?




    Yeah I unplugged the battery for 10 minutes I heard that resets the ECU.
    #3

    Jump to:

    © 2020 APG vNext Commercial Version 5.5