Go back to home



We have detected that you are using ad blocking software.
The MR2 Australia forum is made possible by ad revenue.
Please disable your ad blocker to ensure that this site lives on.

Omori 45mm Boost Gauge Fault

Author
Adrifto
MR2 Master
  • Total Posts : 48
  • Scores: 26
  • Reward points: 881
  • Joined: 2017/12/16 18:09:03
  • Status: offline
2020/05/23 13:06:23 (permalink)
0

Omori 45mm Boost Gauge Fault

Looking for some help from any boost gauge gurus around here.

I have been trying to fix my 45mm Omori boost gauge that has been acting up, and I think I have tracked the issue down but wanted to check.

When checking for continuity on the wire from the gauge to the solenoid, should there be continuity between the black and white wires at all? I'm finding that the black and white posts of the gauge itself have a small amount of continuity, which could be throwing off my reference signal.

Any help would be greatly appreciated.
 
EDIT: New issue. The boost gauge is now reconnected, performing the calibration sweep (-30 to +30 clockwise and back to -30) correctly, however when the engine is idling it sits at 32 psi, and when boost begins to build the needle moves counter clockwise. It moves proportional to the boost building/throttle application, so the reference signal seems to be sending correctly, but being interpreted incorrectly.
post edited by Adrifto - 2020/05/23 16:08:56
#1


1 Reply Related Threads

    TwoDogs
    MR2 Aficionado
    • Total Posts : 283
    • Scores: 12
    • Reward points: 2124
    • Joined: 2013/09/20 10:48:25
    • Status: offline
    Re: Omori 45mm Boost Gauge Fault 2020/05/24 07:21:14 (permalink)
    0
    sounds like polarity might be reversed.
    #2
    Jump to:

    © 2020 APG vNext Commercial Version 5.5