Go back to home



We have detected that you are using ad blocking software.
The MR2 Australia forum is made possible by ad revenue.
Please disable your ad blocker to ensure that this site lives on.

Hot!Boost issues

Author
Sw2091
MR2 Enthusiast
  • Total Posts : 199
  • Scores: 3
  • Reward points: 1847
  • Joined: 2016/01/30 00:35:15
  • Status: offline
2019/02/28 15:59:46 (permalink)
0

Boost issues

Car doesn't seem to be boosting properly in first or idle. Boost only comes in towards the end of the rev range. Other gears are fine

1990 sw20 turbo

Sent from my SM-G955F using Tapatalk

#1


4 Replies Related Threads

    Sw2091
    MR2 Enthusiast
    • Total Posts : 199
    • Scores: 3
    • Reward points: 1847
    • Joined: 2016/01/30 00:35:15
    • Status: offline
    Re: Boost issues 2019/02/28 19:24:29 (permalink)
    0
    Edit: first gear doesn't get boost till about 40km/h and 2nd no boost till about 60km/h

    Sent from my SM-G955F using Tapatalk

    #2
    5SGTE
    MR2 Deity
    • Total Posts : 1922
    • Scores: 162
    • Reward points: 3906
    • Joined: 2011/04/07 19:51:15
    • Location: qld Australia
    • Status: offline
    Re: Boost issues 2019/02/28 22:10:10 (permalink)
    0
    Got any way to pressure test your intake?
    #3

    Sw2091
    MR2 Enthusiast
    • Total Posts : 199
    • Scores: 3
    • Reward points: 1847
    • Joined: 2016/01/30 00:35:15
    • Status: offline
    Re: Boost issues 2019/02/28 22:43:21 (permalink)
    0
    5SGTE

    Got any way to pressure test your intake?

    No i don't unfortunately

    Sent from my SM-G955F using Tapatalk

    #4
    5SGTE
    MR2 Deity
    • Total Posts : 1922
    • Scores: 162
    • Reward points: 3906
    • Joined: 2011/04/07 19:51:15
    • Location: qld Australia
    • Status: offline
    Re: Boost issues 2019/03/01 08:29:24 (permalink)
    0
    If your in SE QLD I could help you out.

    NVM just read you're in SA.
    #5
    Jump to:

    © 2019 APG vNext Commercial Version 5.5